Новые правила для разработчиков

Вместе с выпуском новой, пятой по счету бета версии прошивки 3.0 Apple объявили о новых правилах для приложений, отправляемых на публикацию в App Store. Отныне все они должны быть совместимы с iPhone OS 3.0. Естественно, сборки могут иметь минимальные требования 2.х.х, но поддержка последней прошивки просто обязательна.

Кроме того, специалисты Apple утверждают, что все уже опубликованные приложения хоть и должны по умолчанию поддерживаться iPhone OS 3.0, но проверить их разработчикам стоит просто даже ради того, чтобы не получить внезапно отказ в продолжении продаж/раздачи. Который может явиться следствием тысяч жалоб после выхода полной версии прошивки. Другими словами – скачайте хотя бы SDK 3.0 и проверьте все еще раз. Лишним не будет.

Личный опыт показывает действительную необходимость во введении подобного правила. Хоть и “должно все работать”, но долго не думая и не вспоминая, могу назвать сразу три некорректно работавших приложения: айЧиталка, которая не хотела убирать бары (исправлено), BeejiveIM, которое вылетало в beta 3 при попытке перевернуть телефон горизонтально (работает в beta 5) и Feeds, которое как не добавляло у меня каналы в iPhone OS 3.0, так и не добавляет.

Если какой-то части разработчиков эта новость в тягость и вовсе не прибавляет веселья (лишь море дополнительной работы), то обычным владельцам iPhone она должна понравиться. Только представьте – тестеры App Store отныне будут рассматривать все приложения на iPhone OS 3.0. Звучит? Еще как! Это может означать только одно – прошивка достигла определенной стабильности и пригодна к использованию.

Источник: iphones.ru

Читайте также  Дети любят iPhone
Лучшее для себя